Back to overview
Consent Forms and Consent Form: Microsoft Forms are down
Jan 16 at 05:56am GMT
Affected services
Consent Form: Microsoft Forms
Resolved
Jan 16 at 05:56am GMT
Consent Form: Microsoft Forms recovered.
Affected services
Resolved
Jan 16 at 05:56am GMT
Consent Form: Microsoft Forms recovered.
Affected services